FIXED ITSELF: 'You've run out of hard-disk space'...?

EDIT: a force-refresh seems to have fixed this, so consider the following a minor bug report/insufficient documentation note.

Hi, Gingko’s just started telling me: ‘Card was not saved. You’ve You’ve run out of hard-disk space Clear some space to continue.’

I can’t see anything about how to clear up space, or what my limits might be, or how to check how much I’ve used, so I’m wondering if this might be just a bug?


Hi @oolong.

For the record (and for others reading this), this is referring to hard-drive space on your machine, nothing Gingko related per-se. Clear space as you normally would (delete unused files, etc)


Hi Adriano, I ran into this problem again yesterday. I had around 3GB of hard drive space at the time I think - much less than ideal, but it seems a little odd that something like Gingko would demand much more than that?

Thanks again!

I just ran into the very same issue.

‘Card was not saved. You’ve You’ve run out of hard-disk space Clear some space to continue.’

I was wondering if it has to do with the servers?
I have way over 150GB free on my hard drive …
And is it even saved locally if I do not hit export?
(In fact, made a backup just in case).

How best to proceed now?
Thanks …


I’m getting that error message in the browser version, and I have over 129GB of space on my hard disk. This is rather urgent because I can’t afford to keep working if the data is not being saved.

Thanks for your help.

Hi there,

This has happened a few more times than usual lately, so I’m looking into a fix.

In the meantime, switch to a different browser than you normally use, and all should be well. (sucks, I know :unamused:)

(for more info: Chrome claims a portion of your hard-drive space, and distributes it to all the web apps that you normally use… which is why Gingko can run out of hard disk space, simply because of the quota that Chrome set, even though you have plenty of free space)

Boy, that really does suck. I’m a die-hard Chrome user. Thanks for responding so fast. I also just sent you an email about this.

Would closing tabs in Chrome help this situation? I have more than 140 open tabs at the current time.

Or perhaps turning off some Chrome extensions? I’ve often pushed Chrome to the limits (more than 400 open tabs at one time), and I’ve never seen this error before, so I’m wondering what’s different about Gingko that causes it to use local disk space. For the record, I’m also running some custom CSS I wrote in Stylish.

what’s different about Gingko that causes it to use local disk space.

I cache requests that get sent, so that if they fail, they’re still saved locally. This is the basis of offline mode with Gingko as is.

Probably I’m saving too much, and probably Chrome has recently changed their quota rules… will update here when I know

1 Like

For clarification, here’s how Chrome calculates how much space is available for each application: pool

Here’s an excerpt:

The shared pool can be up to 1/3 of the of available disk space. Storage already used by apps is included in the calculation of the shared pool; that is to say, the calculation is based on (available storage space + storage being used by apps) * .333 .

Each app can have up to 20% of the shared pool. As an example, if the total available disk space is 60 GB, the shared pool is 20 GB, and the app can have up to 4 GB. This is calculated from 20% (up to 4 GB) of 1/3 (up to 20 GB) of the available disk space (60 GB).

I’m still using too much space for Gingko, and I’ll correct that. But it does mean that clearing a few more files (if you can) in the meantime can resolve this for you. @Bunnyslippers also reported by email that closing Chrome completely fixed the issue.

Does “apps” here refer to apps being used by Chrome or all apps on the machine? With 139 GB free on my hard disk, it’s hard to believe Gingko* is using over 45GB … and this is the BROWSER version we’re talking about, not the desktop version. But you’re right – after relaunching Chrome, I haven’t seen the problem reoccur. Let’s keep our fingers crossed.

*BTW, it kills this English major to spell it that way. I have a gorgeous ginkgo (hah!) in my front yard that I planted 30 years ago, so it’s personal. :wink:

Another BTW: The common misspelling “Ginkgo” for the tree is not originally English, but is a German mistake :slight_smile: by Engelbert Kaempfer (1651-1716). See “The Ginkgo Pages” at:
I am glad that Adriano’s software is easier to spell. The tree is still beautiful :slight_smile:
Apologies for OT post.

“apps” refers to anything you’ve visited that stores data in your browser… it’s true that 45GB is ridiculous, and as I’ve said, it might be a bug (maybe on my end, maybe in Chrome).

As for “Gingko” vs “Ginkgo”, yes thanks @ukuest! I couldn’t find that link. The fact that the original term is one person’s choice of romanization of the chinese word/ideograph might make you feel less anxious about mispelling it :wink:

Thanks for the info, @ukuest. Always ready to learn.

@Adriano, that bugger hasn’t reappeared since I relaunched Chrome two days ago, and I’ve added many times the small amount of content (only 3 or 4 cards!) that triggered it the first time.

P.S. @ukuest, Life’s too short to deny oneself the pleasure of an occasional OT post – especially when it’s for educational purposes. :slight_smile: Carry on.

I have also started getting this error message this week (I wasn’t using Gingko much in previous weeks, but it was the Christmas season), and my changes are not being saved when this error occurs. I am using Chrome on a couple of Chromebooks, with different amount of free disk space (17GB on one, 3.4GB on the other). I have two accounts in the household, and both give the same error, even though one has very few Gingko trees in it. The error is reproduced with all extensions turned off, and in Incognito mode. The error message is not entirely consistent (it happens more often on the 17GB machine, than on the 3.4GB machine, so that seems to make little sense). Also, when both trees are open on both machines (logged in as same user), the one with more free space (17GB) gives the error message and wouldn’t save changes, but when I make changes to the same tree in the 3.4GB machine, the changes are saved and displayed in both. The two Chromebooks are near perfect copies of each other, i.e. all extensions and most apps are installed on both and both browsers are synced with each other and local data is synced with Google Drive (where I have 107GB free space). This is kind of a critical issue as it is preventing me from using the app, so I’m hoping some kind of a solution could be found soon. Restarting the browser didn’t help. I’m on Version 64.0.3282.41 (Official Build) beta (64-bit) on the 17GB machine, and Version 62.0.3202.97 (Official Build) (32 bit) on the 3.4GB one. I will test later whether this problem also occurs on my Windows 7 machine.

Update: Gingko (web version) works fine on my Windows 7 laptop. Right now the problem is only occurring on my Dell Chromebook 13 (model 7310). It has a 32GB SSD, and 17.1GB is free for my use. Any suggestion how I could stop this error from happening? (Gingko on my other Chromebook, with a 16GB SSD and 3.6GB free space, is working fine.) Thanks.

Noted @drandus

I am going to remove offline mode for a time, because I believe that’s the cause of it. I can’t just “flip a switch” though: because of the way ServiceWorkers work, I need to be very careful, otherwise Gingko could become 100% unreachable (your devices will be looking in your local offline cache for the app, which will be emptied).

Will post back here when I have updates.

UPDATE (Sun, Jan 7, 6pm EST): I deployed a very temporary fix. Refresh (or force refresh, with Ctrl+F5), and then close all Gingko windows. Then open it again. Error message should go away for long enough that I can get a more complete fix going.

Thank you, Adriano. Actually neither of the “refreshes” worked on my Dell CB13 (they gave me an error message saying "your work was NOT SAVED etc.), but closing the tab and then re-opening the Gingko site did the trick. Thanks again.

P.S. The only other difference I can think of between the two Chromebooks is that on the Dell CB13 I have also installed CrossOver Chrome OS (beta), which I don’t have on the small Asus C100. Even though CrossOver is not running, I wonder if it still somehow reserves a lot of space, affecting the allocation for Gingko offline. Considering that CrossOver is emulating Windows XP, it might require quite a bit of space.

Thanks for the followup.

Yes, Service Workers are tricky in that refreshing doesn’t install the latest one (it queues it for install on next close/reopen).

But I believe I fixed the problem that was taking up all the space, so if you’re experiencing this error, a few open-close cycles should bring you up to the latest version and clear that up. (post here, if you find otherwise)

It’s all working fine. Thanks very much for fixing it. :+1: