Gingko Desktop Beta


#61

TLDR; Gingko is for 64-bit computers

You probably already know this, but just an FYI for other people like me who might’ve missed the memo. :slight_smile:

=====
I downloaded the file called Gingko Setup 0.2.0.exe and tried to install it. I couldn’t get it to work, but I wasn’t surprised, because I don’t have admin rights at my workstation.

I tried it at home this morning (Windows 8.1 laptop, Intel Core i3-3217U, 64-bit OS, x64-based processor). At first nothing seemed to happen, so I clicked it again, and it started to run 2 instances. I cancelled one. The other one ran for a bit, and then claimed “setup failed: MSVCP140.dll missing.”

At this point, I figured I had downloaded the wrong file, since the welcome message specified “no install.” In the middle of downloading, I suddenly saw a Gingko program running! (Except my download wasn’t done, so it could only have come from the setup file.)

Mysterious and wonderful! Unfortunately, I didn’t have time to mess around with it any more, so I just copied everything to a flash drive to try again at work.

Alas, my office workstation (Windows 7 Professional, SP1; Intel Core2 Duo CPU E7500; 32-bit O/S) was more definite in the error message when tried running Gingko.exe after unzipping Gingko-latest-windows.zip: “This version of the file is not compatible with the version of Windows you’re running. Check your computer’s system information to see whether you need an x86 (32-bit) or x64 (64-bit) version of your program, and then contact the software publisher.”

Oh, well. I’ll use the online version at work, but I can’t wait to try the desktop version again when I get home!


#62

Oops! Thanks for the info. I think I can build 32-bit versions as well. If so, I’ll definitely include them as well.


#63

Thank you! Only if you have time, of course… after all, when all is said and done, 32-bit computers will eventually phase out. :slight_smile:


#64

Adriano, I see that Kathryn’s running v1.4.14 on El Capitan. I’m also running El Capitan. I just downloaded Gingko yesterday from the link I received from you by email, and it’s only v. 0.8.2. What is the latest version, and how can I get it?


#65

And the Dropbox link you posted on another thread contains v0.1.7 for Mac. Perhaps it would be a good idea to remove or update those links.


#66

I’m not seeing a file with the .swp suffix in the same directory as the original file. Does this feature still exist?


#67

The version numbers here were a bit confused, because people were finding the version of the underlying technologies I was using. As of today (2017-12-19), 0.8.2 is the latest version.

I’ve removed those files from the dropbox to avoid confusion, and I’m closing this topic as it’s old.
Thanks all!


#68