Gingko Desktop Beta


#41

Thanks for trying this out.
Yes, Latex is not implemented yet, and I haven’t done too much on the Markdown side to bring all those extra options in.

Right now my focus has been on stability/autobackups, etc. I just rewrote that portion of the app, so will be releasing a new version for testing it out soon.


#42

Regarding JSON exports: I was able to successfully import my online tree into the desktop app. But when I try to export in the desktop app, nothing happens. It lets me select the file name and all, but the file just doesn’t appear. This is true both for JSON and MD exports.

I’m on a Mac.


#43

Can you tell me which version number you downloaded? I’ll have a look when I can.


#44

v1.4.14 on Mac (El Capitan)

This is a little all over the place but here are my initial thoughts:

Personally the card titles annoy me because I use the card up one rung in the tree as the title, but I can also see how they’d come in handy if I was using it differently. Also I have some very sprawling trees and the title text gets smaller than the body text pretty quickly which half defeats the point of having a title.
I’d definitely like it to be a feature I can turn off though! Not least because importing my trees from the web app to the desktop means all my cards’ first lines are now titles when they were just all body text stuff.

Command L etc creates the new card where I’d expect but it’s not automatically open for editing which is pretty annoying/disruptive - I’ve never not wanted to write in a new card I’ve created this way!

Think other people have mentioned copy/paste-ing text not working.

A help window/option/something with a command cheat sheet would be useful. I mean I know a bunch from the web app obviously but some aren’t implemented yet and some I can’t always quite remember so having to go online to look them up is a minor frustration.

Personally I like being able to drag and drop my cards when I’m reorganizing so I’d appreciate that feature. Particularly for moving stuff around in a thesis which definitely has a “I will need to include this somewhere but not sure where yet” section.

These

sections don’t have a scroll bar but nor do they wrap, plus they kind of hang over the edge of the card oddly. And I use them for code and stuff so there are some pretty long lines

For Kevin’s root card discussion I like the idea of having all your trees on one page BUT in that case I’d also like the option to show/hide trees. I have a some that are completely unrelated to each other (e.g. my thesis and a recipe database) and I don’t want to have to see them all cluttering up my screen all the time. Also it’s going to make scrolling through a level/rung might get weird and confusing.
(fwiw I also like the idea of being able to use root cards for tree-wide preferences)


#45

How can I check the version? I downloaded whatever was the newest version on Jan 31st.


#46

@gestaltist, the version number is contained in a text file called “version”, contained in the compressed file.


#47

@Adriano,
Here is my experience installing Gingko.
OS: Lubuntu (a flavour of Ubuntu) Xenial 16.04.2 Long Time Support.
Gingko Version: Linux 1.4.14

I will just describe the installation and first steps since I do not know the Gingko app which already exists and so I have no expectations whatever to test :slight_smile:

  1. Download of the .zip file SMOOTHLY. REMARK: There is no checksum (md5 or sha and the like) given for the downloader to check the integrity of the download. This would perhaps make sense and it is not a big deal to do (at least on linux).
  2. Creating a directory on desktop for gingko, unpacking gingko there: SMOOTHLY
  3. Recognizing that Gingko is the executable file, checking the permissions: everybody can execute. SMOOTHLY.
  4. Starting Gingko with ./Ginkgo, since this directory is not in the path (for everybody knowing a minimum of linux). SMOOTHLY and quick on my old machine.

Here is the Terminal output after starting Gingko. Might be of use to you:


benno@taurus:~/Schreibtisch/gingko$ ./Gingko
{ Error: ENOENT: no such file or directory, open '/home/benno/Schreibtisch/gingko/userinfo.txt’
at Error (native)
at Object.fs.openSync (fs.js:640:18)
at Object.module.(anonymous function) [as openSync] (ELECTRON_ASAR.js:173:20)
at Object.fs.readFileSync (fs.js:508:33)
at Object.fs.readFileSync (ELECTRON_ASAR.js:506:29)
at App.createWindow (/home/benno/Schreibtisch/gingko/resources/app.asar/electron-start.js:25:30)
at emitTwo (events.js:111:20)
at App.emit (events.js:191:7)
errno: -2,
code: ‘ENOENT’,
syscall: ‘open’,
path: ‘/home/benno/Schreibtisch/gingko/userinfo.txt’ }


No problems starting Gingko.

Saving “the test file” and importing it back in .json went SMOOTHLY,
Saving it in Markdown too, but reimporting it via “import file” or “open file” failed.
F11 for Fullscreen and back: SMOOTHLY.


I hope this is of use for you. I saw the wonderful picture with your son making his first steps and I would like to support you and your family with my modest knowledge.
Best regards

philipple from Basel, Switzerland.


#48

Hello there, thanks for your wonderfull tool.
Using it in a desktop mode is a big improvment for me in a network-less environment.

Unfortunately, I use a Mac OS X and the fact that we can’t Copy/Paste, as already reported is a big NO.
Is there any workaround on this topic ?
Is there any way to help/contribute fixing that error?

best regards


#49

+1

v.0.1.3 copy and paste is still not honored

Steps to reproduce

  1. Copy something to clipboard (or even try selecting text within Ginko desktop app and copying using command (⌘)-c
  2. ⌘-v to paste in any editable card in Ginko

Expected
Text would be pasted in the editable card

Actual
Nothing seemed to happen

Info
Mac OS X 10.12.15, Ginko v0.1.3


#50

I just downloaded the beta for Windows and unfortunately encountered issues immediately. :frowning:

Reproducible Steps:
I unzipped the app download to my Downloads folder (would not unzip to my Program Files folder) and double-clicked the Gingko app icon.
The app opens to a lovely shade of blue with the menu options at the top.

I did three different things:

  1. I clicked File >> New.
  2. I clicked File >> Open File.
  3. I clicked File >> Import File.

Expected:

  1. (New) I expected a new tree to be created and appear over the blue area.
  2. (Open) After clicking Open File, I expected a file explorer window to open.
  3. (Import) After clicking Import File, I expected a file explorer window to open.

Observed:

  1. (New) Instead, I found that nothing appeared to happen.
  2. (Open) Instead, I found that nothing appeared to happen.
  3. (Import) Instead, I found that nothing appeared to happen.

Info:

  • Windows 7 Professional SP1
  • Gingko 0.1.3

#51

Hi All,

Here’s the state of things for the Desktop beta:

I’ve developed the core of the “gitlike” approach [screencast, 10min], but it’s not ready for release yet.

I’m aware of all these bugs, but I won’t focus on fixing them until I merge those changes (at which point, many might be fixed simply by virtue of using a new version of Electron).

Thanks for the input so far, everyone!
Will announce here (and via email), when I have a new release.


Roadmap of Gingko Desktop development
#52

Hi there,

I’ve been a gingko user on and off the past three years. Today, I tried the desktop version. What I did is I exported a tree from gingko online in json format and imported it to gingko desktop. First thing I noticed is that it defaults to a 6-column view. This makes the cards very narrow which makes for an unpleasant view. How can I make it default to a 3-column view similar to gingko online? I’m using v0.1.4 on windows 7.


#53

I’ll fix this in next release, but in the meantime you can add this code to any card in your tree. Adjust number of pixels to taste:

<style>
.column {
min-width: 450px;
}
</style>

#54

Ok thanks. This will do.


#55

Hello. I have a question about the beta desktop gingko (Windows 10, version 0.1.4)

Is it supposed to be impossible to create new cards under or above the first column? Since you can do that on the chrome app, I figured it’d be available on the desktop version, but I can’t seem to do it, neither with the normal interface, or with keyboard shortcuts.

Thank you for your attention.


#56

Hi @Hoanui,

Yes, I changed this already, and it’ll be ready for next release.

Thanks for your input!
Adriano


#57

Here’s an issue I found. I used the windows 10 interface (gingko version 0.1.4) to set the gko files to load with the exe in appdata, but when I double click the file, it opens gingko with a blank window.

Steps: right click on the gko file, open with… , more apps, look for another app on this pc, point it towards the exe in appdata (C:\Users\ username \AppData\Local\Programs\gingko-client\Gingko.exe))

it sets the file icon nicely, and when I double click the file, it opens gingko, but with a new blank tree, not the tree correspondent to the file I double clicked.


#58

Hi there,

You are right, opening by double-click isn’t implemented yet. It’s on the list.


#59

Windows 10 user here! I really like the current colours, first of all. I don’t mind the green of the web app, but the kind of blue used for this offline version is kinda cool. Anyway (very subjective input).

I’m bothered by the fact that I cannot seem to open a card for editing using Ctrl+Enter. I can exit/close the card with that key combo; I need to click on the edit button to open it.

Lots of functionality still missing of course, so I guess I’ll come back to trying it out further once some elements (esp. making use of key combinations) have been added!

Keep the good work going!

Kind regards,

CK


#60

Hi @Krottsy

Thanks for the input :slight_smile:

You can use Enter to edit the cards, and Ctrl+Enter to save it. That’s the way it works on the web app as well, but I also added Ctrl+Enter to edit, so you can toggle easily. Will do the same for desktop app.